Gefällt dir dieser Artikel?

Guru Plug: Absturz durch Gigabit Ethernet

erschienen in der Kategorie Technik, am 15.07.2012
Schnatterente
Ich habe mein Home-Netzwerk neu verkabelt und mir im Zuge dessen einen Gigabit-Switch zugelegt. Mein Guru Plug Server Plus ist davon gar nicht begeistert.

Seit einigen Jahren betreibe ich einen Guru Plug Server Plus von Globalscale als Daten-, Web- und SVN-Server in meinem Heimnetzwerk. Viele Probleme hat er mir bisher nicht gemacht. Doch gestern war er auf einmal nicht mehr über das Netzwerk erreichbar. Ich dachte mir nicht viel dabei, schaltete die Steckdose ab und wieder ein. Einige Zeit später versuchte ich wieder den Server zu erreichen, doch er war immer noch nicht verfügbar.

Als ich mir das Gerät näher anschauen wollte, stellte ich fest, dass es kochend heiß war - so heiß, dass ich anfänglich dachte, es sei innen schon durchgeschmort und ein Fall für die Mülltonne. Verbrannt roch der Guru Plug jedoch nicht, also ließ ich ihn erst einmal auskühlen und versuchte es dann erneut. Über's Netzwerk war noch immer nichts zu machen, also schloss ich das JTAG-Board an, um dem Problem auf den Zahn zu fühlen.

Folgendes Verhalten offenbarte mir die Minicom-Konsole: Der Guru Plug Server versuchte zu Booten, schaffte es dabei auch noch das Debian-Kernelimage zu entpacken und stürzte dann ab. Dieser Vorgang lief in einer Endlosschleife. Etwas verwirrt und im Glauben, der Plug Computer habe wahrscheinlich wirklich einen Hitzeschaden davon getragen, trennte ich alle angeschlossenen Geräte und Kabel und versuchte es erneut.

Und siehe da - die Bude startete wieder. Just in diesem Moment fiel mir dann auch ein, was ich verändert hatte, der Guru Plug hing seit neuestem an einem 1GBit/s Switch.

Um den Guru Plug Server wieder zum Abstürzen zu bringen, musste ich nur das LAN-Kabel wieder in einen der Netzwerkports stecken. Was ein dämlicher Hardware-Bug?! Da wirbt Globalscale, überall wo die Specs auftauchen, noch damit, dass der Guru Plug zwei Gigabit-LAN Anschlüsse hat und dann so ein Sch**ß!

Nachdem ich nun wusste, was das Problem ist, fand ich auch sehr schnell heraus, dass ich nicht der einzige bin, der es hat. In den Weiten des WWW finden sich haufenweise Guru Plug Nutzer, deren Spielzeug am Gigabit-Ethernet scheitert. In einem Forum fand ich auch noch ein Statement von Globalscale selbst:

The current becomes high while connecting 1Gb Ethernet cable to Guru board, Maybe this will cause the board to work in unstable state. Connecting to 10/100Mb will not have the reboot issue.

We know the issue and is trying to identify the root cause and find the solution with Marvell. Once the solution is confirmed, we will inform you (our customer).


Problemlösung: Netzwerk Downgrade

Ich gehe nicht davon aus, dass es für dieses Problem allzu bald eine Lösung geben wird, vielleicht lässt es sich softwaremäßig auch gar nicht beheben. Daher muss der Guru Plug wieder auf 100 MBit/s gedrosselt werden.

Im Handel gibt es fast nur noch CAT 5e Kabel zu kaufen und meinen alten Switch wollte ich nicht wieder, auch nicht zusätzlich, anschließen, hatte ich mir doch extra ein energiesparendes Model zugelegt (Zyxel GS-105B - zieht gerade einmal 1 Watt). Also musste das vorhandene Netzwerkkabel dran glauben. Ich schnitt einen der Stecker ab und montierte mit der Crimpzange einen neuen. Dabei kontaktierte ich nur die, für 100MBit/s notwendigen, vier Kabelenden - ein Downgrade vom Gigabit-LAN- zum ISDN-Kabel quasi.

Der Guru Plug findet's toll, stürzt nicht mehr ab und wird auch nicht mehr ganz so heiß. Von der Idee schneller Daten von ihm ziehen zu können, kann ich mich wohl aber für's Erste abschreiben.

Geschnatter

0 Kommentare, selbst mitschnattern
Diesen Beitrag hat noch niemand kommentiert. Möchtest du den Anfang machen ?