Gefällt dir dieser Artikel?

Hilfe! 5.1 Sound via USB Soundkarte am Raspberry Pi

erschienen in der Kategorie Technik, am 22.03.2014
Schnatterente
Liebe Nerds, ich brauch mal eure Hilfe. Ich bin auf der Suche nach einer 5.1-fähigen USB-Soundkarte, die unter Linux sauber und ohne Störgeräusche läuft. Das Ding sollte möglichst direkt vom Kernel unterstützt werden und ohne proprietäre Treiber auskommen. Ich möchte sie an einen Raspberry Pi mit RaspBMC anschließen.

Ich habe hier noch einen alten Creative Sound Blaster X-Fi 5.1 rumliegen. Der wird auch weitestgehend erkannt. Ich habe es aber nie geschafft, den mit PulseAudio ordentlich zum Laufen zu kriegen. Entweder es gehen nicht alle Kanäle, oder der Ton ist verzerrt, bzw. verrauscht.

Kennt jemand von euch eine USB-Soundkarte, die out of the box oder mit vertretbarem Konfigurationsaufwand gut läuft? Falls ja wäre ich am Namen und wenn möglich auch an der Vendor- und Device-ID interessiert (also dem Output von # lsusb).

Danke.

Nachtrag: Ich habe gerade noch das hier gefunden. Ich werde mir das mit dem Sound Blaster wohl doch noch mal anschauen, bin aber dennoch für Hinweise zu funktionierenden Karten dankbar. :)


Nachtrag 15.04.2014:
Da ich inzwischen mehrfach Nachfragen per Mail erhalten habe, ob es inzwischen läuft: Ich habe es hinbekommen meinen Soundblaster X-Fi sauber unter Gentoo Linux am Laptop einzurichten (ohne Störgeräusche und mit PulseAudio). Seitens des Raspberry Pi läuft die Karte unter RaspBMC, wenn man in den Einstellungen aktiviert, dass externe Soundkarten genutzt werden sollen.
(Benutze das aktuelle Stable-Release (XBMC Version 12). Die Beta von XBMC 13 und die Alpha von der 14 laufen auf meinem Pi nicht gut.)
Allerdings läuft der Sound nicht wirklich stabil. Wenn man im Video vorspult, ist der Ton weg und bleibt auch weg. Stelle ich den Ton von Stereo auf 5.1, ruckeln die Videos beim Abspielen. Das größte Problem ist aber die Tatsache, dass RaspBMC nach dem Aktivieren der externen Soundkarte nur noch mit dieser Videos abspielt. Trennt man sie vom Gerät, kann man keine Videos mehr gucken (auch dann nicht, wenn man den Haken für die externen Soundkarten im Menü wieder raus nimmt). Die USB-Soundkarten-Unterstützung ist eben noch experimenteller Natur.

Für Testzwecke habe ich mir auf einer zweiten SD-Karte Gentoo-Linux installiert und XBMC auf dem System per Hand kompiliert. Das hat nach einigen Problemen auch geklappt, mit der Soundkarte kommt die Software aber noch nicht klar. Ich denke, wenn ich noch ein paar Sachen ändere, wird der Sound wahrscheinlich funktionieren. Es stellt sich dann aber noch die Frage, ob es der Raspberry Pi schafft Videos flüssig mit 5.1-Sound abzuspielen.

Geschnatter

4 Kommentare, selbst mitschnattern << < Seite 1/1 > >>
Harald, am 22.03.2014 um 13:24 Uhr
glaube ein Freund von mir hat irgendein Audiointerface von Trust, dass wohl gut geht

ich frag mal nach
Ben, am 22.03.2014 um 13:43 Uhr
Ich kämpfe seit einigen Monaten mit dem gleichen Problem, XFi und RPi. Von dem XFi gibts wohl versch. Versionen bzw. Revisionen - einige gehen mit Linux gut, andere nicht.
Anonym, am 23.03.2014 um 00:48 Uhr
Kannste knicken. Gibt keine vernünftigen 5.1 USB soundkarten für Linux.
Muhkuh, am 23.03.2014 um 02:56 Uhr
Ich kann dieses rauschen und ähnliche Effekte auch mit der PCIe-Version des X-Fi bestätigen, mit purem ALSA läuft es aber ohne Probleme. Evtl. geht das auch mit der USB-Variante und evtl. kann man auf Pulseaudio verzichten.